Category : php

I have inherited a symfony project thats in version 3.4. I’m told this project needs composer v1 to run, not the latest v2. I am PHP 7.4.21 installed. I downgraded composer and ran ‘composer update’ and got the ‘[OK] All assets were successfully installed.’ However, I cant run the project, if I use ‘symfony server:start’ ..

Read more

php bin/console doctrine:fixtures:load Careful, database "DoctorHelp" will be purged. Do you want to continue? (yes/no) [no]: y purging database loading AppDataFixturesAppFixtures loading AppDataFixturesArticleFixtures In Lorem.php line 95: join(): Argument #2 ($array) must be of type ?array, string given doctrine:fixtures:load [–append] [–group GROUP] [–em EM] [–purger PURGER] [–purge-exclusions PURGE-EXCLUSIONS] [–shard SHARD] [–purge-with-truncate] Source: Symfony..

Read more

I faced with that error again, have a look please "require-dev": { "dbrekelmans/bdi": "^0.3.0", "symfony/panther": "^1.1", [email protected]:/auth_service# /usr/lib/chromium/chromium –version Chromium 90.0.4430.212 [email protected]:/auth_service# drivers/chromedriver –version ChromeDriver 90.0.4430.24 (4c6d850f087da467d926e8eddb76550aed655991-refs/branch-heads/[email protected]{#429}) and error FacebookWebDriverExceptionUnknownErrorException: unknown error: Chrome failed to start: exited abnormally. (unknown error: DevToolsActivePort file doesn’t exist) (The process started from chrome location /usr/bin/chromium is no longer running, ..

Read more

I have the following error: You cannot use the "SymfonyComponentMessengerBridgeAmqpTransportConnection" as the "amqp" extension is not installed. I am completely sure that I have already installed it. Also running php -m and composer check-platform-reqs shows amqp is installed. Also, I checked php.ini, I have it there. I tried to reinstall it via the following command, ..

Read more

Some time ago everythig works fine, but after rebuild my image I faced with error composer json "require-dev": { "dbrekelmans/bdi": "^0.3.0", "symfony/panther": "^1.1", I chcked version chromium and driver [email protected]:/auth_service# /usr/lib/chromium/chromium –version Chromium 90.0.4430.212 [email protected]:/auth_service# drivers/chromedriver –version ChromeDriver 90.0.4430.24 (4c6d850f087da467d926e8eddb76550aed655991-refs/branch-heads/[email protected]{#429}) when I try to use $this->panterClient = Client::createChromeClient( ‘/usr/bin/chromedriver’, [ ‘–remote-debugging-port=9222’, ‘–no-sandbox’ ], [‘request_timeout_in_ms’ => ..

Read more