Category: laravel

Increasing composer memory limit on AWS (mmap() failed: [12] Cannot allocate memory)

Ive been trying to composer install and composer update on an EC2 AWS instance, and it always hangs on same package: symfony$thanks.json Reading /root/.cache/composer/repo/https—repo.packagist.org/provider-symfony$thanks.json from cache Im aware that I probably need to increase memory size for this action so…

Laravel: Undefined offset 0 in symfony/http-foundation when requiring SimpleSAMLphp

I’m attempting to upgrade dependancies on a simple Laravel 5.7 application that authenticates the user via SimpleSAMLphp, then displays some information it gets from an external API. It looks like something changed between version 4.3.8 and version 4.4.0 of the…

Some error show on my laravel project with on server how i can solve this please help me [duplicate]

Declaration of SymfonyComponentTranslationTranslatorInterface::setLocale($locale) must be compatible with SymfonyContractsTranslationLocaleAwareInterface::setLocale(string $locale) my php php version 7.1 i am upload my laravel website but this error is show again in again please give me solution what can i do to solve this Source:…

Is Laravel with Doctrine a viable solution for Domain Driven Design? [closed]

I would very much appreciate your opinion. I have an existing Laravel project that I have been working for some time. https://github.com/mchekin/rpg At some point, as I became more familiar with DDD, and as I realized that Eloquent (being an…

Updating laravel 6.0 from 5.8 error with symfony

when I tried to update my laravel proyect from version 5.8 to 6.0 we received an error with simfony Mi composer.json: { “name”: “laravel/laravel”, “description”: “The Laravel Framework.”, “keywords”: [“framework”, “laravel”], “license”: “MIT”, “type”: “project”, “minimum-stability”: “dev”, “require”: { “php”:…

How to downgrade symfony/console, can’t install composer package?

i need to use this package mrjgreen/db-sync, i’m using laravel version 5.8. When i try to install it on my project through composer, it returns the following error: Your requirements could not be resolved to an installable set of packages….

Tailing a log within Laravel never executes Symfony Process callback

I’m trying to tail a log file using a console command to detect specific errors. However, the call back in the run(…) portion of my script is never called in the Symfony Process: use IlluminateConsoleCommand; use SymfonyComponentProcessProcess; class MonitorLogs extends…