Category : deprecation-warning

I have a problem. After updating to Symfony 4.4 I got the following deprecation warning Support for mapping keys in multi-line blocks is deprecated since Symfony 4.3 and will throw a ParseException in 5.0. 2x in AccountControllerTest::testSettings from AppTestsController 1x in AccountControllerTest::testPageUser from AppTestsController I have absolutely no clue what this means. testSettings from AppTestsController: ..

Read more

I have stuff like @import ‘../assets/scss/WebsiteBundle/font.scss’; in scss/WebsiteBundle/default.scss, however, since Symfony 4.4 I get the following depracitation warning. Loading the file “../assets/../_photo.scss” from the global resource directory “…/src” is deprecated since Symfony 4.4 and will be removed in 5.0. I can’t seem to find anything in the documentation about this. Can someone help me? Source: ..

Read more

I’m trying to upgrade a Symfony instance from 2.8 to 3.0, and, while I was checking the deprecations in profiler, I found: The TwigTemplate class implements Twig_TemplateInterface that is deprecated since 1.12 (to be removed in 3.0) (2 times) The TwigLexer class implements Twig_LexerInterface that is deprecated since 1.12 (to be removed in 3.0) The ..

Read more