Category: composer-php

Symfony bundle error configuration via composer installation

i’ve made a bundle that has a DependencyInjection/Configuration as shown below class Configuration implements ConfigurationInterface { /** * Generates the configuration tree builder. * * @return TreeBuilder The tree builder */ public function getConfigTreeBuilder() { $treeBuilder = new TreeBuilder(‘szopen_skebby’); $treeBuilder->getRootNode()…

Error while installing friendsofsymfony/user-bundle and friendsofsymfony/oauth-server-bundle

I was following this tutorial. Problem for me occured when i was trying to install friends of symfony user-bundle and/or oauth-server-bundle via composer. Only thing I found out googling was someone asking same question 12 days ago https://github.com/FriendsOfSymfony/FOSOAuthServerBundle/issues/638 Source: Symfony…

composer require dependency injection, but it is already there

“name”: “symfony/dependency-injection”, “version”: “v5.0.4”, “source”: { “type”: “git”, “url”: “https://github.com/symfony/dependency-injection.git”, “reference”: “86338f459313525dd95f5a012f8a9ea118002f94” }, Thats my composer.lock when Im trying to run composer require php-amqplib/rabbitmq-bundle get this stuff Your requirements could not be resolved to an installable set of packages. Problem…

Increasing composer memory limit on AWS (mmap() failed: [12] Cannot allocate memory)

Ive been trying to composer install and composer update on an EC2 AWS instance, and it always hangs on same package: symfony$thanks.json Reading /root/.cache/composer/repo/https—repo.packagist.org/provider-symfony$thanks.json from cache Im aware that I probably need to increase memory size for this action so…

Symfony Twig – PHP does not satisfy that requirement

I am trying to install Symfony Twig onto my local server, however, it is giving me the following error; composer require twig Using version ^1.0 for symfony/twig-pack ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including…

Installation failed for installing Apache=pack with composer

I run Symfony 4.4 When I install Apache-pack with powershell and composer like below : composer require symfony/apache-pack The installation failed and it said : Symfony operations: 1 recipe (2a9150161ef91a4c31501a86af2f4e35) – WARNING symfony/apache-pack (>=1.0): From github.com/symfony/recipes-contrib:master The recipe for this…