Composer conflict when update

when I try a composer update in my Symfony 5.2 project, there seem to be some conflicts:

Problem 1
    - Root composer.json requires doctrine/doctrine-fixtures-bundle ^3.2 -> satisfiable by doctrine/doctrine-fixtures-bundle[3.2.0, ..., 3.4.0].
    - Conclusion: don't install doctrine/common 2.13.3 (conflict analysis result)
    - Conclusion: don't install doctrine/persistence[1.3.8] | install doctrine/persistence[2.1.0] (conflict analysis result)
    - Conclusion: don't install doctrine/persistence 2.1.0 (conflict analysis result)
    - Conclusion: install symfony/doctrine-bridge v5.2.0 (conflict analysis result)
    - symfony/framework-bundle v5.2.0 conflicts with doctrine/persistence 1.2.0.
    - symfony/framework-bundle v5.2.0 conflicts with doctrine/persistence 1.1.1.
    - symfony/framework-bundle v5.2.0 conflicts with doctrine/persistence v1.1.0.
    - Root composer.json requires gedmo/doctrine-extensions 2.4.42 -> satisfiable by gedmo/doctrine-extensions[v2.4.42].
    - Root composer.json requires symfony/framework-bundle 5.2.* -> satisfiable by symfony/framework-bundle[v5.2.0].
    - gedmo/doctrine-extensions v2.4.42 requires doctrine/common ~2.4 -> satisfiable by doctrine/common[v2.4.0, ..., 2.13.3].
    - doctrine/common[2.13.0, ..., 2.13.2] require doctrine/persistence ^1.3.3 -> satisfiable by doctrine/persistence[1.3.3, ..., 1.3.8].
    - doctrine/common[v2.10.0, ..., 2.12.0] require doctrine/persistence ^1.1 -> satisfiable by doctrine/persistence[v1.1.0, ..., 1.3.8].
    - doctrine/persistence 2.0.0 conflicts with doctrine/common v2.9.0.
    - ........... (from v2.4.0 to v2.9.0)
    - doctrine/persistence 2.0.0 conflicts with doctrine/common v2.4.0.
    - You can only install one version of a package, so only one of these can be installed: doctrine/persistence[v1.0.0, ..., 1.3.8, 2.0.0, 2.0.1, 2.1.0].
    - symfony/doctrine-bridge v5.2.0 requires doctrine/persistence ^2 -> satisfiable by doctrine/persistence[2.0.0, 2.0.1, 2.1.0].
    - Conclusion: don't install doctrine/persistence 2.0.1 (conflict analysis result)

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

I thought I should therefore make compose req doctrine/persistence:2.1.0 but if I do that, I have another error :

 Problem 1
    - doctrine/common 2.13.3 requires doctrine/persistence ^1.3.3 -> found doctrine/persistence[1.3.3, ..., 1.3.8] but it conflicts with your root composer.json require (2.1.0).
    - liip/test-fixtures-bundle 1.11.0 requires doctrine/common ^2.13 || ^3.0 -> satisfiable by doctrine/common[2.13.3].
    - liip/test-fixtures-bundle is locked to version 1.11.0 and an update of this package was not requested.

I’m very confusing..

Source: Symfony Questions

Was this helpful?

0 / 0

Leave a Reply 0

Your email address will not be published. Required fields are marked *