Installation failed, reverting ./composer.json and ./composer.lock to their original content. Symfonuy 4.2

Symfony 4.2
I have a problem when i install composer annotations in terminal with command :

composer require annotations

i have this error

Problem 1
– sensio/framework-extra-bundle[v5.6.0, …, v5.6.1] require symfony/config ^4.4|^5.0 -> found symfony/config[v4.4.0, …, v4.4.16, v5.0.0, …, v5.1.8] but the package is fixed to v4.2.12 (lock file version) by a partial update
and that version does not match. Make sure you list it as an argument for the update command.
– Root composer.json requires sensio/framework-extra-bundle ^5.6 -> satisfiable by sensio/framework-extra-bundle[v5.6.0, v5.6.1].

Use the option –with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

Source: Symfony Questions

Was this helpful?

1 / 0

Leave a Reply 0

Your email address will not be published. Required fields are marked *