composer require orm-fixtures –dev
Using version ^3.3 for doctrine/doctrine-fixtures-bundle
./composer.json has been updated
Running composer update doctrine/doctrine-fixtures-bundle
Loading composer repositories with package information
Your requirements could not be resolved to an installable set of packages.
– doctrine/doctrine-fixtures-bundle[3.3.0, …, 3.3.2] require doctrine/data-fixtures ^1.3 -> satisfiable by doctrine/data-fixtures[v1.3.0, …, 1.4.4].
– doctrine/doctrine-fixtures-bundle 3.3.1 requires doctrine/persistence ^1.3 -> found doctrine/persistence[1.3.0, …, 1.3.8] but the package is fixed to 2.1.0 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
– doctrine/data-fixtures[v1.3.0, …, 1.3.3] require doctrine/common ~2.2 -> found doctrine/common[2.2.0, …, 2.13.3] but the package is fixed to 3.0.2 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
– doctrine/data-fixtures[1.4.0, …, 1.4.2] require php ^7.2 -> your php version (7.1.33) does not satisfy that requirement.
– doctrine/data-fixtures[1.4.3, …, 1.4.4] require php ^7.2 || ^8.0 -> your php version (7.1.33) does not satisfy that requirement.
– Root composer.json requires doctrine/doctrine-fixtures-bundle ^3.3 -> satisfiable by doctrine/doctrine-fixtures-bundle[3.3.0, 3.3.1, 3.3.2].
Use the option –with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
Installation failed, reverting ./composer.json and ./composer.lock to their original content.
Source: Symfony Questions
Was this helpful?
0 / 0