ocramius/proxy-manager error when deploy Symfony 5 app on Heroku

I can’t deploy a Symfony 5 app on Heroku when the app needs ocramius/proxy-manager (required by the doctrine migration bundle).

Here is the error :

>   Problem 1
>     - Installation request for ocramius/proxy-manager 2.7.1 -> satisfiable by ocramius/proxy-manager[2.7.1].
>     - ocramius/proxy-manager 2.7.1 requires php 7.4.0 -> no matching package found.

For reference, the following runtimes are currently available:
PHP:  7.4.11, 7.4.10, 7.4.9, 7.4.8, 7.4.7, 7.4.6, 7.4.5, 7.4.4, 
7.4.3, 7.4.2, 7.3.23, 7.3.22, 7.3.21, 7.3.20, 7.3.19, 
7.3.18, 7.3.17, 7.3.16, 7.3.15, 7.3.14, 7.3.13, 7.2.34, 
7.2.33, 7.2.32, 7.2.31, 7.2.30, 7.2.29, 7.2.28, 7.2.27, 
7.2.26, 7.1.33

Seems like php 7.4.0 is not available according to that list but proxy-manager needs it.

Does anyone know how to fix this issue ?
Thanks for your help.

Source: Symfony Questions

Was this helpful?

0 / 0

Leave a Reply 0

Your email address will not be published. Required fields are marked *