The requested PHP extension ext-intl ^1.1 has the wrong version (7.3.17) installed

When I run composer intall, it gives me this error

"The requested PHP extension ext-intl ^1.1 has the wrong version (7.3.17) installed. Install or enable PHP's intl extension." 

I’ve already unticked the semi-colon in php.ini for extension=intl. I’m using Laragon Full 4.0.16 for my local web server.

This is the composer.jon:

"require": {
        "php": "^7.1.3",
        "ext-intl": "^1.1",

It seems to use the PHP version for the ext-intl. And even though its like that, the condition should still hold true for the requirement.

Using phpinfo() shows:
enter image description here

I’ve looked this up and some people would suggest to use "–ignore-platform-reqs" but it doesn’t really solve the problem although it is a quick work around. Has anyone encountered the same problem?

Source: Symfony Questions

Was this helpful?

0 / 0

Leave a Reply 0

Your email address will not be published. Required fields are marked *