symfony forms not installing – composer

I have been trying to install symfony/form in my project but i am unable to understand the reason for composer to not install it, my current composer.json is :

{
    "name": "EMRP/proj3",
    "license": "proprietary",
    "type": "project",
    "autoload": {
        "psr-4": {
            "": "src/"
        },
        "classmap": [
            "app/AppKernel.php",
            "app/AppCache.php"
        ]
    },
    "require": {
        "php": ">=5.5.9",
        "symfony/symfony": "^3.4",
        "doctrine/orm": "^2.5",
        "doctrine/doctrine-bundle": "~1.0",
        "symfony/swiftmailer-bundle": "~2.3",
        "symfony/monolog-bundle": "~2.11.3",
        "sensio/distribution-bundle": "~5.0",
        "sensio/framework-extra-bundle": "^3.0.2",
        "incenteev/composer-parameter-handler": "~2.0",
        "knplabs/knp-paginator-bundle": "^2.5",
        "friendsofsymfony/user-bundle": "^2.0",
        "egeloen/ckeditor-bundle": "~4.0",
        "itsjavi/bootstrap-colorpicker": "~2.5",
        "twig/extensions": "~1.4",
        "knplabs/knp-time-bundle": "^1.7",
        "liip/imagine-bundle": "^2.3",
    },
    "require-dev": {
        "sensio/generator-bundle": "~3.0",
        "symfony/phpunit-bridge": "~2.7"
    },
    "scripts": {
        "symfony-scripts": [
            "IncenteevParameterHandlerScriptHandler::buildParameters",
            "SensioBundleDistributionBundleComposerScriptHandler::buildBootstrap",
            "SensioBundleDistributionBundleComposerScriptHandler::clearCache",
            "SensioBundleDistributionBundleComposerScriptHandler::installAssets",
            "SensioBundleDistributionBundleComposerScriptHandler::installRequirementsFile",
            "SensioBundleDistributionBundleComposerScriptHandler::prepareDeploymentTarget"
        ],
        "post-install-cmd": [
            "@symfony-scripts"
        ],
        "post-update-cmd": [
            "@symfony-scripts"
        ]
    },
    "config": {
        "bin-dir": "bin"
    },
    "extra": {
        "symfony-app-dir": "app",
        "symfony-web-dir": "web",
        "symfony-var-dir": "var",
        "symfony-bin-dir": "bin",
        "symfony-assets-install": "relative",
        "incenteev-parameters": {
            "file": "app/config/parameters.yml"
        },
        "branch-alias": null
    },
    "minimum-stability": "dev",
    "prefer-stable": true
}

After running the command composer require symfony/form:4.0 i get the following output in cli.

D:wampnewwwwempproj>composer require symfony/form:4.0
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - don't install symfony/form v4.0.0|don't install symfony/symfony 3.4.x-dev
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.30
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.31
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.32
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.33
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.34
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.35
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.36
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.37
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.38
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.39
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.40
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.41
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.42
    - don't install symfony/form v4.0.0|remove symfony/symfony v3.4.42
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.0
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.0-BETA1
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.0-BETA2
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.0-BETA3
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.0-BETA4
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.0-RC1
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.0-RC2
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.1
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.10
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.11
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.12
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.13
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.14
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.15
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.16
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.17
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.18
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.19
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.2
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.20
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.21
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.22
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.23
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.24
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.25
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.26
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.27
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.28
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.29
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.3
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.4
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.5
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.6
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.7
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.8
    - don't install symfony/form v4.0.0|don't install symfony/symfony v3.4.9
    - Installation request for symfony/form 4.0 -> satisfiable by symfony/form[v4.0.0].
    - Installation request for symfony/symfony ^3.4 -> satisfiable by symfony/symfony[3.4.x-dev, v3.4.0, v3.4.0-BETA1, v3.4.0-BETA2, v3.4.0-BETA3, v3.4.0-BETA4, v3.4.0-RC1, v3.4.0-RC2, v3.4.1, v3.4.10, v3.4.11, v3.4.12, v3.4.13, v3.4.14, v3.4.15, v3.4.16, v3.4.17, v3.4.18, v3.4.19, v3.4.2, v3.4.20, v3.4.21, v3.4.22, v3.4.23, v3.4.24, v3.4.25, v3.4.26, v3.4.27, v3.4.28, v3.4.29, v3.4.3, v3.4.30, v3.4.31, v3.4.32, v3.4.33, v3.4.34, v3.4.35, v3.4.36, v3.4.37, v3.4.38, v3.4.39, v3.4.4, v3.4.40, v3.4.41, v3.4.42, v3.4.5, v3.4.6, v3.4.7, v3.4.8, v3.4.9].


Installation failed, reverting ./composer.json to its original content.

Even if i try to install composer require symfony/form without version numbering, i get the same errors but just symfony/form version 4.0 is replaced with [email protected]

What could be the reason.

PS:

I have:
composer clearcache executed.
and deleted composer.lock file.

Source: Symfony Questions

Was this helpful?

0 / 0

Leave a Reply 0

Your email address will not be published. Required fields are marked *