I’m trying to install smalot/cups-ipp package on Symfony 5 but I have dependency issue with required packages.
To install smalot/cups-ipp, I run following command:
# composer require smalot/cups-ipp:dev-master
And result is:
Do not run Composer as root/super user! See https://getcomposer.org/root for details ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Restricting packages listed in "symfony/symfony" to "5.0.*" Your requirements could not be resolved to an installable set of packages. Problem 1 - Installation request for smalot/cups-ipp dev-master -> satisfiable by smalot/cups-ipp[dev-master]. - smalot/cups-ipp dev-master requires php-http/socket-client ^1.0 -> satisfiable by php-http/socket-client[v1.0.0, v1.1.0, v1.2.0, v1.3.0, v1.4.0, v1.4.1] but these conflict with your requirements or minimum-stability. Installation failed, reverting ./composer.json to its original content.
I tried normal version (not dev-master) but I got another dependency issue with symfony/yaml package.
I installed php-http/socket-client which requires symfony/options-resolver.
symfony/options-resolver is in version 5 for Symfony 5. So I installed php-http/socket-client in dev-master version otherwise I have another dependency issue.
So now I have:
# composer show -i symfony/options-resolver v5.0.8 php-http/socket-client dev-master
My problem is that smalot/cups-ipp requires php-http/socket-client in version 1.4, not version 2.0. So do you know how I can force smalot/cups-ipp installation with current php-http/socket-client package which is in dev-master (2.0) version?
Source: Symfony Questions