how can I install one newer symfony package with flex

I want to have an app in symfony 3.4, but to have symfony/dotenv in v4. The dotenv package in version 4.4.8 supports symfony/process 3.4.

But when I run composer update, it fails and only lists 3.4.* as candidate versions. This is probably restricted by extra.symfony.require: 3.4.* in composer.json.

I know it works at least in some cases. I have a project in symfony 3.4 which uses symfony/http-client 4.3. Does this only work because there is no older version?

Where can I find more information about dependency restricting by symfony/flex?

Here are some sources I know:

  1. https://symfonycasts.com/screencast/symfony5-upgrade/version-constraints#symfony-flex-symfony-extra-require-is-a-soft-requirement
  2. https://github.com/symfony/flex/blob/master/README.md
  3. https://flex.symfony.com/

And here the clearest one:

  1. How composer `extra.symfony.require` restriction is enforced?

When extra.symfony.require is a soft requirement (text from 1.), what does this mean? Does this match to 4.?

Source: Symfony Questions

Was this helpful?

0 / 0

Leave a Reply 0

Your email address will not be published. Required fields are marked *