Azure webApp Authorization Header Missing

I have an api developed with symfony that use jwt tokens to autenticate ours users, in local works perfectly in a virtual machone works, the code works rigth.

I like to publish the code in Azure WebApp, but we hace a security issue, because Azure remove the header Authorization the application can’t found the token for the users.

When i send a Authorization Bearer {JWT Token} header, the webapp remove this completly.

I try to use another name for the header and it’s received fine for the application.

How can i make that Azure Webapp don’t intercept this token and pass this to the application.

I disabled the authentication offered by Microsoft to integrate with AD, and other services, but continue removing the header.

This it’s the configuration of the WebApp

{"deployment_branch":"master","SCM_TRACE_LEVEL":"Verbose","SCM_COMMAND_IDLE_TIMEOUT":"60","SCM_LOGSTREAM_TIMEOUT":"7200","SCM_BUILD_ARGS":"","ScmType":"None","FUNCTIONS_RUNTIME_SCALE_MONITORING_ENABLED":"0","WEBSITE_AUTH_ENABLED":"False","WEBSITE_AUTH_TOKEN_STORE":"True","WEBSITE_AUTH_RUNTIME_VERSION":"~1","WEBSITE_HTTPLOGGING_RETENTION_DAYS":"3","WEBSITE_AUTH_DEFAULT_PROVIDER":"AzureActiveDirectory","LogLevel":"debug","SCM_USE_LIBGIT2SHARP_REPOSITORY":"0","WEBSITE_SITE_NAME":"pdmpg01-back","REMOTEDEBUGGINGVERSION":"16.0.28729.10","WEBSITE_AUTH_UNAUTHENTICATED_ACTION":"AllowAnonymous","WEBSITE_AUTH_LOGOUT_PATH":"/.auth/logout","WEBSITE_AUTH_AUTO_AAD":"False"}

Thanks!

Source: Symfony Questions

Was this helpful?

0 / 0

Leave a Reply 0

Your email address will not be published. Required fields are marked *