Updated symfony in composer.json, but I get an error when trying to install a new package with "require"

I upgrade Symfony to the 5.0 version.

When I run the server, all is right. However, when I use composer (example composer remove tattali/calendar-bundle), I get these errors :

    C:cmderroadtrip>composer remove tattali/calendar-bundle
    Dependency "symfony/framework-bundle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Restricting packages listed in "symfony/symfony" to "5.0.*"
    Your requirements could not be resolved to an installable set of packages.

      Problem 1
        - The requested package symfony/console (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/console[v4.4.4] but these conflict with your requirements or minimum-stability.
      Problem 2
        - The requested package symfony/dotenv (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/dotenv[v4.4.4] but these conflict with your requirements or minimum-stability.
      Problem 3
        - The requested package symfony/filesystem (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/filesystem[v4.4.4] but these conflict with your requirements or minimum-stability.
      Problem 4
        - The requested package symfony/form (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/form[v4.4.4] but these conflict with your requirements or minimum-stability.
      Problem 5
        - The requested package symfony/framework-bundle (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/framework-bundle[v4.4.4] but these conflict with your requirements or minimum-stability.
      Problem 6
        - The requested package symfony/intl (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/intl[v4.4.4] but these conflict with your requirements or minimum-stability.
      Problem 7
        - The requested package symfony/property-access (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/property-access[v4.4.4] but these conflict with your requirements or minimum-stability.
      Problem 8
        - The requested package symfony/security-bundle (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/security-bundle[v4.4.4] but these conflict with your requirements or minimum-stability.
      Problem 9
        - The requested package symfony/serializer (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/serializer[v4.4.4] but these conflict with your requirements or minimum-stability.
      Problem 10
        - The requested package symfony/translation (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/translation[v4.4.4] but these conflict with your requirements or minimum-stability.
      Problem 11
        - The requested package symfony/validator (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/validator[v4.4.4] but these conflict with your requirements or minimum-stability.
      Problem 12
        - The requested package symfony/var-dumper (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/var-dumper[v4.4.4] but these conflict with your requirements or minimum-stability.
      Problem 13
        - The requested package symfony/yaml (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/yaml[v4.4.4] but these conflict with your requirements or minimum-stability.
      Problem 14
        - ocramius/package-versions 1.5.1 requires php ^7.3.0 -> your PHP version (7.2.27) does not satisfy that requirement.
        - ocramius/package-versions 1.5.1 requires php ^7.3.0 -> your PHP version (7.2.27) does not satisfy that requirement.
        - ocramius/package-versions 1.5.1 requires php ^7.3.0 -> your PHP version (7.2.27) does not satisfy that requirement.
        - Installation request for ocramius/package-versions (locked at 1.5.1) -> satisfiable by ocramius/package-versions[1.5.1].


Removal failed, reverting ./composer.json to its original content.

I don’t understand what I must do to solve this problem.

EDIT :

I updated Php to the last version, I resolved all depreciations, I changed the doctrine-extensions bundle to a bundle supported by Symfony 5. Now, I get theses errors :

C:cmderroadtrip>composer update knplabs/knp-paginator-bundle
Loading composer repositories with package information
Updating dependencies (including require-dev)
Restricting packages listed in "symfony/symfony" to "5.0.*"
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package symfony/console (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/console[v4.4.4] but these conflict with your requirements or minimum-stability.
  Problem 2
    - The requested package symfony/dotenv (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/dotenv[v4.4.4] but these conflict with your requirements or minimum-stability.
  Problem 3
    - The requested package symfony/filesystem (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/filesystem[v4.4.4] but these conflict with your requirements or minimum-stability.
  Problem 4
    - The requested package symfony/form (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/form[v4.4.4] but these conflict with your requirements or minimum-stability.
  Problem 5
    - The requested package symfony/framework-bundle (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/framework-bundle[v4.4.4] but these conflict with your requirements or minimum-stability.
  Problem 6
    - The requested package symfony/intl (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/intl[v4.4.4] but these conflict with your requirements or minimum-stability.
  Problem 7
    - The requested package symfony/property-access (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/property-access[v4.4.4] but these conflict with your requirements or minimum-stability.
  Problem 8
    - The requested package symfony/security-bundle (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/security-bundle[v4.4.4] but these conflict with your requirements or minimum-stability.
  Problem 9
    - The requested package symfony/serializer (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/serializer[v4.4.4] but these conflict with your requirements or minimum-stability.
  Problem 10
    - The requested package symfony/translation (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/translation[v4.4.4] but these conflict with your requirements or minimum-stability.
  Problem 11
    - The requested package symfony/validator (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/validator[v4.4.4] but these conflict with your requirements or minimum-stability.
  Problem 12
    - The requested package symfony/var-dumper (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/var-dumper[v4.4.4] but these conflict with your requirements or minimum-stability.
  Problem 13
    - The requested package symfony/yaml (locked at v4.4.4, required as 5.0.*) is satisfiable by symfony/yaml[v4.4.4] but these conflict with your requirements or minimum-stability.
  Problem 14
    - symfony/web-server-bundle v4.2.12 requires symfony/console ~3.4|~4.0 -> satisfiable by symfony/console[v4.4.4] but these conflict with your requirements or minimum-stability.
    - symfony/web-server-bundle v4.2.12 requires symfony/console ~3.4|~4.0 -> satisfiable by symfony/console[v4.4.4] but these conflict with your requirements or minimum-stability.
    - symfony/web-server-bundle v4.2.12 requires symfony/console ~3.4|~4.0 -> satisfiable by symfony/console[v4.4.4] but these conflict with your requirements or minimum-stability.
    - Installation request for symfony/web-server-bundle (locked at v4.2.12, required as 4.2.*) -> satisfiable by symfony/web-server-bundle[v4.2.12].

Source: Symfony Questions

Was this helpful?

0 / 0

Leave a Reply 0

Your email address will not be published. Required fields are marked *