Impossible to install react-bundle with composer when using website-skeleton

I have a problem when i create my Symfony app in LTS version with website-skeleton and i try to install react-bundle with this commands: composer require Limenius/react-bundle

I get this error message:

MBP-de-Benjamin:Applications benjaminragot$ composer require limenius/react-bundle
Using version ^4.0 for limenius/react-bundle
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Restricting packages listed in "symfony/symfony" to "4.4.*"
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: remove doctrine/doctrine-bundle 2.0.6
    - Conclusion: don't install doctrine/doctrine-bundle 2.0.6
    - twig/twig v1.20.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.21.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.21.1 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.21.2 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.22.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.22.1 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.22.2 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.22.3 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.23.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.23.1 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.23.2 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.23.3 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.24.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.24.1 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.24.2 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.25.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.26.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.26.1 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.27.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.28.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.28.1 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.28.2 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.29.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.30.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.31.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.32.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.33.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.33.1 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v1.33.2 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v2.0.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v2.1.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v2.2.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v2.3.0 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v2.3.1 conflicts with doctrine/doctrine-bundle[2.0.6].
    - twig/twig v2.3.2 conflicts with doctrine/doctrine-bundle[2.0.6].
    - Installation request for doctrine/doctrine-bundle (locked at 2.0.6) -> satisfiable by doctrine/doctrine-bundle[2.0.6].
    - Installation request for limenius/react-bundle ^4.0 -> satisfiable by limenius/react-bundle[v4.0.0].
    - Conclusion: don't install twig/twig v3.0.0|install twig/twig v1.20.0|install twig/twig v1.21.0|install twig/twig v1.21.1|install twig/twig v1.21.2|install twig/twig v1.22.0|install twig/twig v1.22.1|install twig/twig v1.22.2|install twig/twig v1.22.3|install twig/twig v1.23.0|install twig/twig v1.23.1|install twig/twig v1.23.2|install twig/twig v1.23.3|install twig/twig v1.24.0|install twig/twig v1.24.1|install twig/twig v1.24.2|install twig/twig v1.25.0|install twig/twig v1.26.0|install twig/twig v1.26.1|install twig/twig v1.27.0|install twig/twig v1.28.0|install twig/twig v1.28.1|install twig/twig v1.28.2|install twig/twig v1.29.0|install twig/twig v1.30.0|install twig/twig v1.31.0|install twig/twig v1.32.0|install twig/twig v1.33.0|install twig/twig v1.33.1|install twig/twig v1.33.2|install twig/twig v2.0.0|install twig/twig v2.1.0|install twig/twig v2.2.0|install twig/twig v2.3.0|install twig/twig v2.3.1|install twig/twig v2.3.2
    - Conclusion: remove twig/twig v3.0.0|install twig/twig v1.20.0|install twig/twig v1.21.0|install twig/twig v1.21.1|install twig/twig v1.21.2|install twig/twig v1.22.0|install twig/twig v1.22.1|install twig/twig v1.22.2|install twig/twig v1.22.3|install twig/twig v1.23.0|install twig/twig v1.23.1|install twig/twig v1.23.2|install twig/twig v1.23.3|install twig/twig v1.24.0|install twig/twig v1.24.1|install twig/twig v1.24.2|install twig/twig v1.25.0|install twig/twig v1.26.0|install twig/twig v1.26.1|install twig/twig v1.27.0|install twig/twig v1.28.0|install twig/twig v1.28.1|install twig/twig v1.28.2|install twig/twig v1.29.0|install twig/twig v1.30.0|install twig/twig v1.31.0|install twig/twig v1.32.0|install twig/twig v1.33.0|install twig/twig v1.33.1|install twig/twig v1.33.2|install twig/twig v2.0.0|install twig/twig v2.1.0|install twig/twig v2.2.0|install twig/twig v2.3.0|install twig/twig v2.3.1|install twig/twig v2.3.2
    - limenius/react-bundle v4.0.0 requires limenius/react-renderer ^4.0.0 -> satisfiable by limenius/react-renderer[v4.0.0, v4.0.1, v4.0.2].
    - limenius/react-renderer v4.0.2 requires twig/twig ^1.20|^2.0 -> satisfiable by twig/twig[v1.20.0, v1.21.0, v1.21.1, v1.21.2, v1.22.0, v1.22.1, v1.22.2, v1.22.3, v1.23.0, v1.23.1, v1.23.2, v1.23.3, v1.24.0, v1.24.1, v1.24.2, v1.25.0, v1.26.0, v1.26.1, v1.27.0, v1.28.0, v1.28.1, v1.28.2, v1.29.0, v1.30.0, v1.31.0, v1.32.0, v1.33.0, v1.33.1, v1.33.2, v1.34.0, v1.34.1, v1.34.2, v1.34.3, v1.34.4, v1.35.0, v1.35.1, v1.35.2, v1.35.3, v1.35.4, v1.36.0, v1.37.0, v1.37.1, v1.38.0, v1.38.1, v1.38.2, v1.38.3, v1.38.4, v1.39.0, v1.39.1, v1.40.0, v1.40.1, v1.41.0, v1.42.0, v1.42.1, v1.42.2, v1.42.3, v1.42.4, v2.0.0, v2.1.0, v2.10.0, v2.11.0, v2.11.1, v2.11.2, v2.11.3, v2.12.0, v2.12.1, v2.12.2, v2.2.0, v2.3.0, v2.3.1, v2.3.2, v2.4.0, v2.4.1, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.5.0, v2.6.0, v2.6.1, v2.6.2, v2.7.0, v2.7.1, v2.7.2, v2.7.3, v2.7.4, v2.8.0, v2.8.1, v2.9.0].
    - limenius/react-renderer v4.0.1 requires twig/twig ^1.20|^2.0 -> satisfiable by twig/twig[v1.20.0, v1.21.0, v1.21.1, v1.21.2, v1.22.0, v1.22.1, v1.22.2, v1.22.3, v1.23.0, v1.23.1, v1.23.2, v1.23.3, v1.24.0, v1.24.1, v1.24.2, v1.25.0, v1.26.0, v1.26.1, v1.27.0, v1.28.0, v1.28.1, v1.28.2, v1.29.0, v1.30.0, v1.31.0, v1.32.0, v1.33.0, v1.33.1, v1.33.2, v1.34.0, v1.34.1, v1.34.2, v1.34.3, v1.34.4, v1.35.0, v1.35.1, v1.35.2, v1.35.3, v1.35.4, v1.36.0, v1.37.0, v1.37.1, v1.38.0, v1.38.1, v1.38.2, v1.38.3, v1.38.4, v1.39.0, v1.39.1, v1.40.0, v1.40.1, v1.41.0, v1.42.0, v1.42.1, v1.42.2, v1.42.3, v1.42.4, v2.0.0, v2.1.0, v2.10.0, v2.11.0, v2.11.1, v2.11.2, v2.11.3, v2.12.0, v2.12.1, v2.12.2, v2.2.0, v2.3.0, v2.3.1, v2.3.2, v2.4.0, v2.4.1, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.5.0, v2.6.0, v2.6.1, v2.6.2, v2.7.0, v2.7.1, v2.7.2, v2.7.3, v2.7.4, v2.8.0, v2.8.1, v2.9.0].
    - limenius/react-renderer v4.0.0 requires twig/twig ^1.20|^2.0 -> satisfiable by twig/twig[v1.20.0, v1.21.0, v1.21.1, v1.21.2, v1.22.0, v1.22.1, v1.22.2, v1.22.3, v1.23.0, v1.23.1, v1.23.2, v1.23.3, v1.24.0, v1.24.1, v1.24.2, v1.25.0, v1.26.0, v1.26.1, v1.27.0, v1.28.0, v1.28.1, v1.28.2, v1.29.0, v1.30.0, v1.31.0, v1.32.0, v1.33.0, v1.33.1, v1.33.2, v1.34.0, v1.34.1, v1.34.2, v1.34.3, v1.34.4, v1.35.0, v1.35.1, v1.35.2, v1.35.3, v1.35.4, v1.36.0, v1.37.0, v1.37.1, v1.38.0, v1.38.1, v1.38.2, v1.38.3, v1.38.4, v1.39.0, v1.39.1, v1.40.0, v1.40.1, v1.41.0, v1.42.0, v1.42.1, v1.42.2, v1.42.3, v1.42.4, v2.0.0, v2.1.0, v2.10.0, v2.11.0, v2.11.1, v2.11.2, v2.11.3, v2.12.0, v2.12.1, v2.12.2, v2.2.0, v2.3.0, v2.3.1, v2.3.2, v2.4.0, v2.4.1, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6, v2.4.7, v2.4.8, v2.5.0, v2.6.0, v2.6.1, v2.6.2, v2.7.0, v2.7.1, v2.7.2, v2.7.3, v2.7.4, v2.8.0, v2.8.1, v2.9.0].
    - Can only install one of: twig/twig[v1.41.0, v3.0.0].
    - Can only install one of: twig/twig[v1.42.0, v3.0.0].
    - Can only install one of: twig/twig[v1.42.1, v3.0.0].
    - Can only install one of: twig/twig[v1.42.2, v3.0.0].
    - Can only install one of: twig/twig[v1.42.3, v3.0.0].
    - Can only install one of: twig/twig[v1.42.4, v3.0.0].
    - Can only install one of: twig/twig[v2.10.0, v3.0.0].
    - Can only install one of: twig/twig[v2.11.0, v3.0.0].
    - Can only install one of: twig/twig[v2.11.1, v3.0.0].
    - Can only install one of: twig/twig[v2.11.2, v3.0.0].
    - Can only install one of: twig/twig[v2.11.3, v3.0.0].
    - Can only install one of: twig/twig[v2.12.0, v3.0.0].
    - Can only install one of: twig/twig[v2.12.1, v3.0.0].
    - Can only install one of: twig/twig[v2.12.2, v3.0.0].
    - Can only install one of: twig/twig[v1.34.0, v3.0.0].
    - Can only install one of: twig/twig[v1.34.1, v3.0.0].
    - Can only install one of: twig/twig[v1.34.2, v3.0.0].
    - Can only install one of: twig/twig[v1.34.3, v3.0.0].
    - Can only install one of: twig/twig[v1.34.4, v3.0.0].
    - Can only install one of: twig/twig[v1.35.0, v3.0.0].
    - Can only install one of: twig/twig[v1.35.1, v3.0.0].
    - Can only install one of: twig/twig[v1.35.2, v3.0.0].
    - Can only install one of: twig/twig[v1.35.3, v3.0.0].
    - Can only install one of: twig/twig[v1.35.4, v3.0.0].
    - Can only install one of: twig/twig[v1.36.0, v3.0.0].
    - Can only install one of: twig/twig[v1.37.0, v3.0.0].
    - Can only install one of: twig/twig[v1.37.1, v3.0.0].
    - Can only install one of: twig/twig[v1.38.0, v3.0.0].
    - Can only install one of: twig/twig[v1.38.1, v3.0.0].
    - Can only install one of: twig/twig[v1.38.2, v3.0.0].
    - Can only install one of: twig/twig[v1.38.3, v3.0.0].
    - Can only install one of: twig/twig[v1.38.4, v3.0.0].
    - Can only install one of: twig/twig[v1.39.0, v3.0.0].
    - Can only install one of: twig/twig[v1.39.1, v3.0.0].
    - Can only install one of: twig/twig[v1.40.0, v3.0.0].
    - Can only install one of: twig/twig[v1.40.1, v3.0.0].
    - Can only install one of: twig/twig[v2.4.0, v3.0.0].
    - Can only install one of: twig/twig[v2.4.1, v3.0.0].
    - Can only install one of: twig/twig[v2.4.2, v3.0.0].
    - Can only install one of: twig/twig[v2.4.3, v3.0.0].
    - Can only install one of: twig/twig[v2.4.4, v3.0.0].
    - Can only install one of: twig/twig[v2.4.5, v3.0.0].
    - Can only install one of: twig/twig[v2.4.6, v3.0.0].
    - Can only install one of: twig/twig[v2.4.7, v3.0.0].
    - Can only install one of: twig/twig[v2.4.8, v3.0.0].
    - Can only install one of: twig/twig[v2.5.0, v3.0.0].
    - Can only install one of: twig/twig[v2.6.0, v3.0.0].
    - Can only install one of: twig/twig[v2.6.1, v3.0.0].
    - Can only install one of: twig/twig[v2.6.2, v3.0.0].
    - Can only install one of: twig/twig[v2.7.0, v3.0.0].
    - Can only install one of: twig/twig[v2.7.1, v3.0.0].
    - Can only install one of: twig/twig[v2.7.2, v3.0.0].
    - Can only install one of: twig/twig[v2.7.3, v3.0.0].
    - Can only install one of: twig/twig[v2.7.4, v3.0.0].
    - Can only install one of: twig/twig[v2.8.0, v3.0.0].
    - Can only install one of: twig/twig[v2.8.1, v3.0.0].
    - Can only install one of: twig/twig[v2.9.0, v3.0.0].
    - Installation request for twig/twig (locked at v3.0.0) -> satisfiable by twig/twig[v3.0.0].


Installation failed, reverting ./composer.json to its original content.
MBP-de-Benjamin:Applications benjaminragot$ 

How can i avoid this ?
It appears that when I want to install react-bundle in an Symfony app construct with juste skeleton it work so I need a solution because i don’t know how to get from a skeleton to website-skeleton. It has to be a conflict problem with package of website-skeleton architecture

Source: Symfony Questions

Was this helpful?

0 / 0

Leave a Reply 0

Your email address will not be published. Required fields are marked *